Esta es la lista de iPhones / iPads / iPod touch afectados por las vulnerabilidad de Meltdown y Spectre

Estos días se está hablando mucho del bug que se ha encontrado en todos los procesadores modernos fabricados en los últimos diez años. Después de nuestra explicación sobre este problema, os listamos los dispositivos iOS que se ven afectados por este bug, porque en sus CPUs, existe la posibilidad de sacar partido de esas vulnerabilidades.

iPhone 4S

Repetimos que esto no es un problema del que haya que preocuparse demasiado como usuarios de iOS, porque las Apps que instalamos desde la App Store en teoría no pueden tener código que utilice Meltdown o Spectre para acceder a datos confidenciales debido a que en Apple las comprueban antes de publicarlas. Este es un problema que afecta más a ordenadores o incluso a Android, sistema operativo en el que es mucho más habitual instalar aplicaciones desde fuentes no oficiales. En iOS, la única manera no oficial de instalar una App es utilizando XCode e instalando la App manualmente, algo que hacen usuarios que entre otras cosas, saben lo que están haciendo. Por lo tanto, no hay que alarmarse demasiado, pero en cualquier caso, ésta es la lista de dispositivos iOS en cuyas CPUs de arquitectura ARM existe este problema: Hablamos de procesadores Cortex-A8 (utilizado en el Apple A4), Cortex-A9 (en el Apple A5), y Cortex-A15 (en el Apple A6)

  • iPhone 4
  • iPhone 4S
  • iPhone 5
  • iPhone 5C
  • iPad (primera generación)
  • iPad 2
  • iPad (tercera generación)
  • Apple TV (segunda generación)
  • Apple TV (tercera generación)
  • iPod touch (cuarta generación)
  • iPod touch (quinta generación)

Como aún no se conocen todos los detalles de este problema, es posible que esta lista se amplíe en el futuro. Por ahora, podemos confirmar que los dispositivos iOS afectados son los de la lista de arriba… en los que no hay ningún iPhone moderno. Si la lista cambia, actualizaremos este artículo. El Apple Watch no se ve afectado porque sus procesadores ARM no utilizan el mismo sistema de cache.

Es importante reseñar que algunos de estos dispositivos, como el iPhone 4 o 4S, no pueden instalar iOS 11.2, en donde Apple ya ha implementado un parque que palia en parte este problema, incluso a pesar de la muy baja posibilidad que existe de que el usuario instale una App maliciosa. No sabemos si Apple actualizará versiones anteriores de iOS para incluir un parche para este problema, aunque lo vemos muy poco probable.

1 Comentario

Dejar respuesta

Please enter your comment!
Please enter your name here